5分钟快3首页    注册   登录
5分钟快3 = way to explore
5分钟快3 是一个5分钟快3关于 分享和探索的地方
现在注册
已注册用户请  登录
5分钟快3  ›  程序员

5分钟快3Win 10,发现一些网络请求全部被转到5分钟快3本地 1080 端口,然后失败

  •  2
     
  •   PriestTomb · 7 天前 · 4437 次点击

    最近一段时间莫名其妙出现的现象,比如之前玩 PUBG,任务刷不出来,最近玩古网,发现启动程序会报错,用命令查了一下发现网络请求从5分钟快3本地 1080 端口走,然后就不通了

    报错的情况

    昨天根据古网自己的报错日志,用 postman 访问了一下几个官网更新5分钟快3地址 ,发现也是报错( dos 命令也能看到是走了5分钟快3本地 1080 端口),但用 chrome 打开这些链接就是正常的,在 5分钟快3Win 10 里装的 ubuntu 上,用 curl 命令也能顺利访问

    所以苦恼不知道是系统哪里的设置导致的这种现象,来社区求助下大佬

    第 1 条附言  ·  7 天前

    首先5分钟快3我 昨天已经把本机的 $$ 客户端直接删掉了

    刚才按好几位 pong 友提的建议,依次尝试了:

    1. 检查了 Internet 选项 -> 连接 -> 局域网设置 中的代理配置,内容为空,且没有勾选

    2. 查看系统设置 -> 代理,自动和手动均未打开

    3. 打开 $$ 客户端,开启全局,关闭代理,退出 $$

    4. 系统设置 -> 网络重置

    折腾一番之后,依然没有解决,有一个现象要说一下,启动 $$ 客户端之后,5分钟快3我 把5分钟快3本地 端口改回 1080,然后就算5分钟快3我 没有开启代理( PAC 或全局),问题中描述的情况就能正常了,使用 netstat -ano | findstr "1080" 查看,能看到 $$ 客户端文件夹中的 ss_privoxy.exe 和 $$ 客户端本身还在运行。。

    第 2 条附言  ·  6 天前

    问题解决了,89楼的老哥@ipixeloldc 提到环境变量的问题,因为5分钟快3我 之前为了测 PAC 的问题自己在电脑上也配过 http_proxyhttps_proxy,因为时间太久忘记了,现在删掉之后再重启电脑,一切恢复正常了。

    再次谢谢所有回贴的程序员们,提供了不少5分钟快3帮助 !

    92 回复  |  直到 2019-08-14 20:21:30 +08:00
        1
    Caballarii   7 天前   ♥ 1
    很明显是有代理啊
        2
    stillyu   7 天前 via iPhone   ♥ 1
    ss 一般用 1080 端口?
        3
    ahhui   7 天前   ♥ 1
    5分钟快3你 的代理设置 pac 字段没清空,自己去 Internet 选项,连接,局域网设定,使用自动配置里删一下 pac
        4
    DEANHZED   7 天前 via iPhone
    5分钟快3Win dows10 去设置里点一下就好了。
        5
    PriestTomb   7 天前
    @Caballarii
    @stillyu
    @ahhui
    ss 的客户端不是自己会加 pac 么,5分钟快3我 改了 ss 的5分钟快3本地 端口,5分钟快3Win 10 设置里的那个 pac 5分钟快3地址 也变成其他端口了,比如 http://127.0.0.1:10810/pac,但还是没用
        6
    tt67wq   7 天前
    重装系统吧!
        7
    xfcy   7 天前 via Android   ♥ 1
    同,有时候关掉代理,手动清掉乱七八糟地方的配置,还是会走代理端口。搞不懂是不是哪里漏掉了。
        8
    different   7 天前   ♥ 1
    打开的 shado..wsocks 客户端,开启全局代理,再关闭代理即可。(猜的,)
        9
    different   7 天前
    反正5分钟快3我 之前都是这么解决的
        10
    Osk   7 天前   ♥ 1
    1. 检查是否设置了 PAC
    2. 试试运行: `netsh 5分钟快3Win http show proxy`



    /t/582354
        11
    augustheart   7 天前 via Android   ♥ 1
    这是很明显的上次翻完墙没将 ss 设置为非翻墙的状态直接退出了
        12
    PriestTomb   7 天前
    @different 客户端关闭代理之后,打开日志,依然能看到有请求在走代理。。

    5分钟快3你 说的这个5分钟快3我 再试下
        13
    WuwuGin   7 天前
    去网络里面手动把代理清掉就行了啊。。
        14
    whale   7 天前   ♥ 1
    同时关闭系统的代理设置以及客户端的系统代理;
    另外最简单便捷的操作:网络重置
    http://i.loli.net/2019/08/13/ANpKXd6Pr9iJDZj.png
        15
    aaa5838769   7 天前
    1080 是代理端口。
        16
    PriestTomb   7 天前
    @Osk 三楼说的 Internet 选项里5分钟快3我 看了,是有个5分钟快3本地 的 pac 5分钟快3地址 ,这个是要删掉吗?但删掉之后 ss 也没法用了好像,启 ss 之后还是会设置 pac

    netsh 5分钟快3Win http show proxy 这个命令5分钟快3我 晚上回去再查一下,办公的电脑刚才查了一下,显示“直接访问(没有代理5分钟快3服务 器)”
        17
    augustheart   7 天前 via Android
    @PriestTomb ss 客户端有三种工作模式。5分钟快3你 不会是从来没设置过吧…
        18
    PriestTomb   7 天前
    @augustheart 昨天帮忙看问题的哥们也是这么说,可能是之前退出的操作导致的,不过5分钟快3我 有点没明白,5分钟快3你 的意思是说关掉 ss 客户端的时候,难道需要先停掉代理,再退出程序么?5分钟快3我 一直都是直接退出,不管是有没有开代理
        19
    different   7 天前   ♥ 1
    @PriestTomb 5分钟快3你 试试5分钟快3我 说的,关掉客户端之后,再打开,开启全局代理,再关闭,再退出即可
        20
    PriestTomb   7 天前
    @whale 好的谢谢,5分钟快3我 晚上再试下,实在不行重置一下看看
        21
    hellwys1   7 天前   ♥ 1
    代理的问题吧。
    N 卡 geforce experience 的 helper 之类也会莫名其妙占用 1080。看看哪些在用 1080 然后杀掉。
        22
    PriestTomb   7 天前
    @augustheart PAC 和全局?要么就不开?
        23
    augustheart   7 天前 via Android
    @PriestTomb 对,ss 的内部工作方式就是5分钟快3你 开启代理它就设置5分钟快3你 的系统代理的 pac 并且启用,选择不代理(不记得选项是哪四个字)就取消掉系统代理启用 pac 的那个勾。直接退出不做任何操作,保持最后的状态
        24
    PriestTomb   7 天前
    @hellwys1 1080 端口查不到有程序在占用,貌似就是楼上的各位说的,有代理没清干净,5分钟快3我 再试试
        25
    PriestTomb   7 天前
    @augustheart 系统的代理是指动态代理?使不使用 pac 脚本的话是有个开关的吧,5分钟快3我 测试过直接退 ss 客户端,这个会关闭的哎,5分钟快3你 说的是这个么?

    http://i.loli.net/2019/08/13/nLAtx3Nj9zgp21v.png
        26
    augustheart   7 天前
    @PriestTomb 5分钟快3你 这一说5分钟快3我 拿5分钟快3公司 的 5分钟快3Win 7 试了一下还真的会自动取消……
    5分钟快3我 之前在家用 5分钟快3Win 10 测试确实是5分钟快3我 说的这么回事。
    5分钟快3我 现在也有点迷糊了……
        27
    augustheart   7 天前
    @PriestTomb 但是现象确实不变。
    启用全局模式,访问 duckduckgo 可以打开,然后直接关掉 ss,duckduckgo 打不开了。
    目测还有一个设置的地方,但是一下子5分钟快3我 想不到在哪
        28
    augustheart   7 天前
    @PriestTomb 错了错了,上面这个测试有点丢人……
    5分钟快3我 干个活醒醒脑去,脑子有点不清醒
        29
    augustheart   7 天前
    @PriestTomb
    写了几行代码醒醒脑,然后上 github 找 ssr 客户端的源码看看。大致是这么回事吧。在 ShadowsocksController.cs 这个文件的注释里面写了原因
        30
    augustheart   7 天前
    @PriestTomb 5分钟快3我 的号发不了内容,第 400 行
        31
    PriestTomb   7 天前
    @augustheart 哈没研究过客户端的源码,这个细节(或者说 BUG )八成会修复的吧
        32
    exev2   7 天前   ♥ 1
    请检查这里。


    SS 自带的代理模式和 PAC 不用频繁切换,如果只有浏览器需求,chrome 装 SwitchyOmega 扩展,单独控制浏览器代理。不会和系统代理冲突。
        33
    PriestTomb   7 天前
    @exev2 ss 退出之后,自动代理的脚本也会变成关闭的状态(图在 25 楼,这一层再带链接回复居然被警告了。。),请问这个 PAC 脚本还会影响到系统其他的5分钟快3软件 么?
        34
    whileFalse   7 天前   ♥ 1
    ls 都没说对。ss 正常退出会自动关闭代理,下次启动再按照之前的状态(走或者不走代理)恢复。
    但如果暴力把客户端杀掉,或者系统崩溃,ss 就无法自动关闭代理,此时系统设置的网络就挂了。

    如果5分钟快3你 浏览器有 switchyOmega 之类的扩展,浏览器是不理会系统代理设置的,所以此时可以正常工作。
        35
    whileFalse   7 天前
    有一些应用是能够识别并使用系统代理的,这些会受影响。有很多应用不理会系统代理设置,就不受影响。
        36
    ThirdFlame   7 天前
    不要让 SS 设置系统代理。
        37
    augustheart   7 天前
    @whileFalse 不需要暴力退出,只需要右键退出就能复现了。
    4.7 版 ssr
        38
    augustheart   7 天前
    @whileFalse
    在切换回直连模式之前右键退出,可能会导致甚至连 baidu 都上不了的问题。
    5分钟快3我 又做了几次测试,5分钟快3我 怀疑问题可能出在解析域名上……
    开始做了两次测试确实都不能打开,后来重复测试到第三次的时候每次都能打开了。
        39
    augustheart   7 天前
    @ThirdFlame
    再测试了一下,5分钟快3我 自己又排除了解析域名的可能。因为打开其它网址也没问题了……
        40
    augustheart   7 天前
    @ThirdFlame
    @错了…………不好意思
        41
    way2create   7 天前
    1080 一般就是代理 小飞机默认设置退出了应该不会影响的 5分钟快3我 也没设置全局代理
        42
    PriestTomb   7 天前
    @different
    @Osk
    @whale
    @different
    依次测试了各位的5分钟快3方法 。。甚至直接网络重置,依然还是这样。
    5分钟快3我 重新把 ss 开到 10800 端口上,这些出问题的地方依然会被导向 1080 端口。。

    ![port10800.jpg]( http://i.loli.net/2019/08/13/bmVazy9T5FrA4WJ.jpg)
        43
    iPhoneXI   7 天前 via Android   ♥ 1
    5分钟快3我 上次遇到这个情况是开了 proxifier
        44
    MeteorCat   7 天前 via Android   ♥ 1
    这种情况5分钟快3我 以前直接暴力退出就会出现
        45
    PriestTomb   7 天前
    @iPhoneXI 5分钟快3我 自己这台电脑上没装 proxifier,也没类似功能的5分钟快3软件 来着。。就很尴尬
        46
    PriestTomb   7 天前
    @MeteorCat 上面有老哥说暴力退出的问题了,不过5分钟快3我 电脑也重启过、网络也重置过、现在 ss 配置也换了,还是死命往 1080 端口发。。
        47
    PriestTomb   7 天前
    @whileFalse “ ss 就无法自动关闭代理,此时系统设置的网络就挂了”
    请问这种情况怎么解呢? 5分钟快3Win 10 自己的网络重置试了也没用。。
        48
    MyouiSouth   7 天前   ♥ 1
    5分钟快3你 百度一下 IE 代理设置。。。就第一条结果百度经验里说的那个,把那个勾掉试试
        49
    PriestTomb   7 天前
    @MyouiSouth 这个5分钟快3我 做了
        50
    MyouiSouth   7 天前
    @PriestTomb 这样做了还是没能解决转发的问题吗,还是说遇到了新的问题呢,建议5分钟快3你 把问题更新到主楼里
        51
    MeteorCat   7 天前 via Android   ♥ 1
    @PriestTomb 重置下网络适配器
        52
    PriestTomb   7 天前
    @MeteorCat 是指禁用网卡再启用吗?5分钟快3我 试了一下还是一样的问题
        53
    MeteorCat   7 天前 via Android
    @PriestTomb 这种就尴尬了
        54
    deepdark   7 天前 via Android
    应该是$$开了全局没关,5分钟快3你 想办法把$$关掉
        55
    PriestTomb   7 天前
    @deepdark 5分钟快3我 把5分钟快3本地 的 $$ 都删了。。也是不行,重新装了 $$ 之后开全局再退掉也不行。。
        56
    hahaayaoyaoyao   7 天前
    @PriestTomb 关掉全局,5分钟快3Win 10 到设置里边看一下
        57
    PriestTomb   7 天前
    @hahaayaoyaoyao 25 楼的图就是5分钟快3我 关掉客户端之后的 5分钟快3Win 10 设置页面里的代理那个页面,虽然显示还有 pac 脚本的5分钟快3地址 ,但“使用脚本”那个开关都已经关掉了
        58
    zqjilove   7 天前   ♥ 1
    囧,5分钟快3我 电脑也是这种情况,目前只能是 CMD 命令执行一下 set http_proxy= 来手动清空代理,但是每次开启新命令窗口都要执行,很少头疼。坐等最靠谱5分钟快3方法 、
        59
    FrankHB   7 天前
    只是注意点关掉还好了,有的代理5分钟快3软件 甚至都不提供关掉的选项,每次掉了重连还自动设置一遍,这就很 zz 了……
        60
    yw9381   7 天前 via Android   ♥ 1
    只有5分钟快3我 想问下楼主在哪个区么。5分钟快3我 在 wegame 的梦回太古。楼主要一起么
        61
    PriestTomb   7 天前
    @yw9381 哈哈 5分钟快3我 在官服-梦付千秋,帮忙查问题的5分钟快3技术 客服跟5分钟快3我 说不然先试试 wg 服可不可以玩
        62
    PriestTomb   7 天前
    @zqjilove 5分钟快3你 也是有用 $$ 么?最近出的这种情况?5分钟快3我 感觉是最近更新的 $$ 客户端导致的。。
        63
    zqjilove   7 天前
    @PriestTomb 一直使用,因此无法断定。带上$$又没有设置全局。5分钟快3Win 设置里看到的又是没启用代理的情况。所以也是很无解。只能通过每次重设 set http_proxy= 来临时解决当下的请求
        64
    PriestTomb   7 天前
    @zqjilove 感觉5分钟快35分钟快3我 们 俩的情况一毛一样了。。坐等再看看有没有大神能提供个解决方案吧,实在不行得重装下系统了
        65
    nnnToTnnn   7 天前
    @PriestTomb

    首先5分钟快3你 看看5分钟快3你 的 ss 走的是不是虚拟网卡的 tun2socket,一般 ss

    1. tun 虚拟网卡通过 route 转发流量到 1080 端口
    2. 通过 IE 的系统代理转发流量
    3. 通过劫持系统 API 转发浏览

    大概就是这样,当5分钟快3你 说 dos 都走了系统流量,很可能就是 tun 虚拟网卡转发流量


    解决5分钟快3方法 :

    1. 将 ss 关闭,并且不要设置为开机启动
    2. 使用管理员打开 cmd 执行命令 route -f
    3. 关闭重启电脑
        66
    nnnToTnnn   7 天前
    5分钟快3你 要说一下,5分钟快3你 使用的 ss 的版本以及类型,这样很难猜出来原因是什么
        67
    PriestTomb   7 天前
    @nnnToTnnn $$ 用的是 5分钟快3Win dows 版本的客户端,就是 github 上那个 c# 版本的,客户端的版本用的是 4.1.3.1,最近手动更新到最新的 4.1.7 了。
    5分钟快3你 说的类型,请问这个该怎么查看或者确定呢?这方面是小白,一直都是配好一键用了。。
        68
    kile   7 天前
    这个时候5分钟快3你 需要 360 断网助手...
        69
    exev2   7 天前
    @PriestTomb 一般关掉是不会影响的。

    5分钟快3你 在附言中提到:

    启动 $$ 客户端之后,5分钟快3我 把5分钟快3本地 端口改回 1080,然后就算5分钟快3我 没有开启代理( PAC 或全局),问题中描述的情况就能正常了。

    这就对了,正常情况下 SS 运行后;
    系统代理模式> [直连模式] ,不需要走 [PAC 模式] 和 [全局模式] 。
    代理规则> [全局]

    使用 netstat -ano | findstr "1080" 查看,能看到 $$ 客户端文件夹中的 ss_privoxy.exe 和 $$ 客户端本身还在运行。。

    这很正常,本来如此。只要启动 SS 客户端之后,ss_privoxy.exe 就会一并开启同时工作。这个 privoxy 程序是和 SS 打包在一起的,负责 socks 转发到 http,为不支持 socks 协议的程序提供 http 代理连接。
        70
    PriestTomb   7 天前
    @kile 这个用了,没效果。。
        71
    jiangyang123   7 天前
    这个就是 5分钟快3Win 10 的奇妙 bug 导致的

    也许下次 5分钟快3Win 10 升级之后问题就消失了说不定
        72
    nnnToTnnn   7 天前
    @PriestTomb

    是这个客户端吗?

    http://github.com/shadowsocks/shadowsocks-5分钟快3Win dows

    如果是这个就简单了,打开 IE 浏览器

    + http://jingyan.baidu.com/article/48b558e356aac17f38c09a80.html

    把<为 lan 使用代理5分钟快3服务 器> 关掉就行了
        73
    nnnToTnnn   7 天前   ♥ 1
    shadowsocks-5分钟快3Win dows 走的是系统 IE 代理,PAC 和全局代理的模式仅仅只是把国内的 ip/域名加入了白名单不走代理而已
        74
    PriestTomb   7 天前
    @exev2
    这就对了,正常情况下 SS 运行后;
    系统代理模式> [直连模式] ,不需要走 [PAC 模式] 和 [全局模式] 。
    代理规则> [全局]

    5分钟快3我 启动客户端后虽然没有“启动系统代理”,但因为它同时启动了 ss_privoxy.exe ,就依然会把请求转发到 1080 去?因为5分钟快3我 打开$$客户端的日志能看到这时候那些被转发到 1080 端口的请求还在连接5分钟快3我 的$$5分钟快3服务 器(虽然5分钟快3我 没开启代理,但这些请求却能连接成功$$5分钟快3服务 器),这个让5分钟快3我 有点疑惑。。
        75
    PriestTomb   7 天前
    @nnnToTnnn 5分钟快3你 说的这个5分钟快3我 也做过了。。昨天直接重置了系统的网络,重启电脑后这些代理配置全是空的,但依然不行。。
        76
    PriestTomb   7 天前
    @jiangyang123 5分钟快3我 注意到这个现象大概有一个月了,emm 如果是系统的 bug 那就很尴尬了。。
        77
    nnnToTnnn   7 天前
    @PriestTomb 检查一下 IE 的代理配置,并截图。

    截图两个地方

    1. IE 的代理设置哪里
    2. 任务结束管理器

    然后5分钟快3我 在看一下
        78
    jiangyang123   7 天前   ♥ 1
    @PriestTomb #76 只是猜的啦
    但是 5分钟快3Win 10 的确经常有些说不清道不明,怎么也没法解决的 bug
    试试重装系统或者等他升级吧
        79
    nnnToTnnn   7 天前
    @PriestTomb ss_privoxy.exe 好像是为了兼容 http 代理,负责将 http 转换给 socket5 协议,这个无法劫持5分钟快3你 的系统网络
        80
    exev2   7 天前   ♥ 1
    @PriestTomb 在 ss_privoxy.exe 同目录下,有一个 privoxy.conf 配置文件,把内容全部复制出来5分钟快3我 看下。
    5分钟快3你 这个系统看起来像是被其它代理程序干扰过一样。
        81
    tabris17   7 天前
    > netsh
    > 5分钟快3Win http
    > show proxy
        82
    PriestTomb   7 天前
    @nnnToTnnn 晚上回去5分钟快3我 再截一下,5分钟快3公司 的电脑因为都正常,所以不能作为参考了,不过。。那个“任务结束管理器”是啥。。
        83
    PriestTomb   7 天前
    @exev2 那台电脑上压根没有 privoxy.conf 这个文件。。5分钟快3我 双击 ss_privoxy.exe 的时候,它有弹窗提示5分钟快3我 没找到这个 conf 文件。。难道就是这个问题?(八成是被5分钟快3我 另一个5分钟快3软件 给拦截了)

    ```
    listen-address 127.0.0.1:65202
    toggle 0
    logfile ss_privoxy.log
    show-on-task-bar 0
    activity-animation 0
    forward-socks5 / 127.0.0.1:10811 .
    hide-console
    ```

    这是另一台正常的电脑上的配置,5分钟快3我 把这个文件直接复制过去看看?
        84
    exev2   7 天前
    @PriestTomb 5分钟快3你 可以试一下,一般默认都是有 conf 文件的。
    [forward-socks5 / 127.0.0.1:10811 .] 这个 10811 要和5分钟快3你 SS 选项设置里的5分钟快3本地 端口号一致。
        85
    PriestTomb   7 天前
    @exev2 嗯好的,这个5分钟快3我 前两天发现了,但不知道这个是干嘛用的。。5分钟快3我 晚上试下
        86
    exev2   7 天前
    @PriestTomb 这个就是 privoxy.exe 的配置文件,privoxy.exe 正常工作以及如何工作,就是依赖 privoxy.conf 文件来执行的,相当于一般5分钟快3软件 的选项设置功能,只不过这个没有 GUI 界面而已。
        87
    PriestTomb   7 天前
    @exev2 soga,谢谢
        88
    nnnToTnnn   7 天前
    @PriestTomb 就是看进程的那个玩意
        89
    ipixeloldc   6 天前 via iPhone   ♥ 2
    5分钟快3我 这边也因为梯子没流量出现过各种客户端网络错误的情况,并且开着 s*d(一个变种版本)和不开着,错误代码还是不一样的.....和楼主后来补充的情况是一样的。后来5分钟快3我 发现了问题是因为5分钟快3我 环境变量里面设置了 http_proxy 和 https_proxy....后来删了,重启就没毛病了....
        90
    PriestTomb   6 天前   ♥ 1
    @ipixeloldc 老哥牛逼!!!5分钟快3你 一说环境变量5分钟快3我 突然就想起来了,5分钟快3我 之前为了测个东西,自己配了 http_proxy 和 https_proxy。。一打开果然还在,就是指定了 1080 端口,删了重启果然恢复正常了。。多谢老哥!!
        91
    PriestTomb   6 天前   ♥ 1
    @zqjilove 兄弟检查一下环境变量,是不是有配在了环境变量里
        92
    zqjilove   6 天前
    @ipixeloldc @PriestTomb 真是环境变量里设置了,不记得有自己有添加过,找了很多地方,完全没想到环境变量里设置,太感谢了,5分钟快3删除 重启,解决问题了。
    5分钟快3关于   ·   FAQ   ·   API   ·   5分钟快35分钟快3我 们 的愿景   ·   广告投放   ·   感谢   ·   实用小5分钟快3工具   ·   3285 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 25ms · UTC 04:16 · PVG 12:16 · LAX 21:16 · JFK 00:16
    ♥ Do have faith in what you're doing.